Vapefly TGO with fingerprint technology

Vapefly TGO (Touch to Go)
Big thanks to Vapefly for supplying their latest release the Vapefly TGO. The Vapefly brand have been in existence since 2017 and have established themselves as purveyors of quality vaping equipment with their own R & D unit & the experience of the highly rated German103 team. With the TGO they have introduced fingerprint technology to a mod bringing security, child safety & prevents accidental misfire. Please read on to see if this indeed innovative or a pain in the backside.

In The Box

The TGO comes well packaged with a picture of the mod on the front with company branding. On the rear is the contents list, company details & scratch & check sticker next to the mod/colour information. Outer sleeve & box lid removed reveals the TGO pod & removing the top tray leaves you with a USB C charge lead, 2 coils, fold out manual & fingerprint set up how to card.

Battery 2300mAh built-in battery
Power 5-70W
Working Voltage 1.2V-4.2V
Coil TGO mesh coil 0.3Ω/0.6Ω
Charging Port Type-C
Time Cut off 10s
E-juice Capacity 4.5ml
Screen 0.96 inch TFT screen
Dimension 5023102mm
Material Zinc alloy & PCTG

The first fingerprint Pod Mod

Child lock & private

0.02s fast unlock

Advanced fingerprint mode and communication mode

Smart protections: 3minutes Lock/Accidental Touch/Child Lock/Low Battery/High Temperature/10s Cut off/Short Circuit/Over Charge Protection

Colour Pearl White, Obsidian Black, Tiffany Blue, Camaro Yellow, Black Red, Ruby Red, Gunmetal|

Setting Up Fingerprint Lock

On first start up out the box you are prompted to set up the fingerprint recognition. Two ADMIN prints need setting up, 1 & 2. 3 to 6 can be set but are not required.

Power device on by clicking x5 times

Press fire button to access fingerprint screen

You will need x2 ‘admin’ or user fingerprints

Choose fingerprint number with + and – button

Press fire button to begin fingerprint capture

Repeat 6 times until green light flashes

To add other users fingerprints, press fire button and + and repeat

To delete fingerprint press fire and –

I was pleasantly surprised how faff free this was having nearly thrown a phone through a window over its inability to recognise one fingerprint. As I tend to thumb fire right handed & index left handed, that’s what I set up. In use there were very few missed fires and it helps that the fire button needs a firm press to actually activate. What is really impressive is that it can’t be fired by inanimate objects like keys/change in a pocket & without having to put the mod into a locked mode. It locks the fire button after 3 minutes. The +/- buttons are locked by default requiring simultaneous +/- press to unlock, so no pulling the mod out of a pocket/bag & vaping on a volcano because power has been set to max. The fingerprint lock can be switched off for 24hrs by three presses on the fire button to put it in Communication mode. Three presses will reenable the lock.

In Use

Once the fingerprints are set it’s time to get to the important stuff & see how it vapes. The pod is held in place by 4 strong magnets & there’s zero movement once in place. The coil is push fit taking note of the squared sides to line up correctly. A few drops of e-juice to begin priming the coil, push it in & time to fill. The pod has a clever top fill opened by pushing down on the raised arrow & pushing towards the airflow control (AFC). This is easier to do with the pod in situ as it’s quite stiff at first. The pod has a black top, so it’s better to remove the pod to see how much juice is in otherwise you risk overfilling & ending up with juice squirting out of the fill hole. There are cut outs in the mod body & by tilting it forward it’s possible to see the juice level rising but is difficult to see in a dark environment. The AFC is knurled & easy to rotate without being loose. The fire button is quite large, to accommodate the fingerprint technology & has a solid feel when pressed but no clicking. Around the fire button is an LED that lights red if it doesn’t recognise the fingerprint & green when it does. Fortunately for battery life it only does this from a locked state along with haptic feedback. Below the fire button is a clear well presented 0.96” TFT screen. At the top is mode & battery level. Below is a speedo style power meter which increases/decreases as you set the watts. Below that is the watts, Ohms & Volts & at the bottom puff/time counters & a fingerprint symbol to show it’s set FP lock & greyed out when in Communication mode (24 hr unlock). A padlock symbol next to power shows the +/- buttons are locked.

When fitting the pod, you get the haptic feedback & auto selects the power, 30w for the 0.3ohm & 20w for the 0.6ohm coil. To adjust power simultaneously press both +/- and use either to go up/down. Both coils worked well at the pre-set & up to the max for my tastes & both are quite happy with 70/30 juice. AFC is a little vague until halfway closed & the vape becomes a bit more condensed without feeling restricted. The 2 extra airflow holes in the body under the juice windows meant this doesn’t shut down tight although this would also be determined by using MTL coils with a narrow bore. Flavour on both coils was good using my standard testing juice, a dessert Butter 03, & the fruity Pear Fizz was very good. As I’ve found out trying various pod/low ohm systems most are better with lighter fruity flavours, but a shade dull on desserts/custards, but these coils are in the top 2/3 I’ve tried.

Round up

To sum up, is the FP technology a positive or negative. It worked without issue unless I wasn’t contacting the fire button right so that’s user error not a mod problem. Once set up, not difficult to do, it worked as well as any other mod. Firing is quick & positive, display has all the info you need. Pods don’t leak (yeah) & the top fill works well if a little small/tight. Would be nice to have the option to swap drip tips but the built in one isn’t bad. Menu system is easy as there’s few options to actually change. You can select one of four modes from std, sport, eco & vpc plus puff reset after hitting the fire button 4 times & using +/- to scroll through. Runtime is decent on the 0.6 coil but unexpectedly lower on the 0.3 although charging wasn’t the quickest given it’s USB C. Tested at around 1.5A charge current took 1.5hrs to charge from 20% to full. The finish on the mod is top quality. Paintwork is exceptionally good with a white pearlescent main colour & the GT sports car stripes in black on the review mod. Logos are subtle without detracting the look & buttons are all responsive & no rattling. It’s not the lightest mod pod for it’s size but it looks & feels solid. Also bonus points for being compatible with Smok RPM40 coils giving a wider range to choose from.

To be honest the only gripe I have with this is every time I plugged in to charge the mod said it was fully charged until I unplugged/plugged the USB C lead. This happened on the supplied lead as well as 2 other leads. Since this was written Vapefly have been made aware & a firmware fix is planned

Thanks again to Vapefly for providing the TGO pod kit. More info here


Thanks for the review @nwhornet, interesting.


As @Tworrs said, very interesting …


Well @Tworrs and @SessionDrummer said it all.

Nice review!


Well @Tworrs @SessionDrummer & @WickedFog said exactly what i wanted to say so…nice review! :raised_hands:t2:

Man I’m so lazy these days :roll_eyes:


What @Steampugs said

You are not as lazy as me bud (i will not be out lazied)


:rofl: wetsuits


A post was merged into an existing topic: Share your tried and tested recipes

Yeah I’m with @Tworrs, @SessionDrummer, @WickedFog, @Steampugs eah I’m with @Tworrs, @SessionDrummer, @WickedFog, @woftam
(Something went wrong there but I’m going with it)
Great review thanks, not really sure I’m ready for this FP technology in mods being all thumbs :joy: but very interesting ! :+1:


Just set it up to your thumbs then :joy:.


Haha Yeah, actually I’m just like you, thumb right and index left ( thought it was just me :crazy_face:) just I don’t like fire buttons that you have to hit just right , picked up the LADON when it came out and I frigging Hate the fire button, have to hit it just right at the top of the button, very annoying.