Problems with my Aegis Legend


#1

hello guys, im having nothing but problems with my legend 200 watt, constantly saying atomizer short even with new coils in the aero tank, even tried it with a different tank. dont know what to do now.


Aegis Legend Kit, Hit or Myth? - Woftam
#2

I don’t know the mod but I would start by taking a good look at your 510 connection and also cleaning it with a q-tip and a little alcohol. I try to do this every time I screw a tank on. Sometimes a metal chip or tiny shaving from machining gets loose and shorts the connection. If you see anything remove your batteries and use tweezers to remove it.


#3

tried this to no avail. thanks for the reply.


#4

Good advice @mrpipes!!
@steve just curious if you charge your batteries thru your mod? The reason I ask is, my RX200 would read atomizer error if I charge thru the mod. Or it was simply a dirty 510 which @mrpipes has mentioned…


#5

yes eddie i do charge through the mod, do u think if i tried new batteries this might help.


#6

@Sprkslfly and @SmilingOgre your expertise is requested.


#7

any help is much apreciated


#8

No, probably not… I don’t think it’s the batteries. We do have incredibly smart folks here so I’m sure someone will have some answers for you…


#9

Lets see what these guys say but it sounds to me like it is somewhere in the 510. The protective circuit is working [?] keeping it from firing. Juice running down or even condensation can cause some of these to do this. You may have to disassemble and have a good look at the 510 and signs of loose wiring or components. I suspect they will be along shortly and may have better ideas.


#10

You might try updating the firmware as @woftam posted above. Even if you have done this, you might try it again. Other than this I’m stumped and hate to tell you to disassemble unless you are comfortable with such things.


#11

tried earlier this evening to do firmware update but when i got to the download part it wasnt allowing me to download, was asking me to use z7 when i said ok it just wouldnt open, im at a total loss, dont want to bin it .


#12

It wants you to use 7 zip to open it. here is a zipped version for you


#13

Does the mod have a restore to factory default function? If so try that. Sometimes these downloads make everything wonky for no apparent reason.
edit. Whoops, didn’t know woftam was posting.


#14

not that i can see.


#15

thanks woftam, just ran the firmware update succesfully and still same problem,when screen lights upcoil shows 0.00,volt 0.00 amp 0.00 power running at 75w.


#16

Other than the firmware upgrade I’m at a loss. I didn’t know that you had tried to upgrade and unless you know you had a tank leaking, then I’m leaning towards the upgrade as the problem. support@geekvape.com might help.


#17

really apreciate everyone help.thanks


#18

Hi =)

Well two of the ‘basics’ have already been suggested (or covered):

  1. Try different tanks to eliminate the possibility of a bad atty, or series of cartridges (assuming the atties are different brands and use different coils). You could have an entire blister pack of bad coils… Which is why I mentioned different brand atty, but given how many fit in different brands these days, I figure I better specify…

  2. Cleaning the 510 has already been suggested. Which is great for the exterior, but does nothing if the short is inside. (more soon)

  3. The other thing I would mention is taking a small pick (as in: probing device) and trying to see if you can pull UP on the center (positive) pin.
    There are certain atties which have excessively long male 510 connectors, and if the female 510 connection is too shallow, it tends to “bottom out” the center pin, sometimes “permanently” locking them in place.

As for the “more”… What’s more is if liquid has gotten down into the device, with these being a “sealed unit” (waterproof, etc), you’re pretty much screwed.


#19

If that ever “fixes” a device, my first recommendation would be to unload it instantly. Because there’s bigger issues… For starters a crap chip going into an indeterminate state, or firmware by shitty programmers. Neither of which bode well for a mod with hopes of longevity. :wink:


#20

7zip by chance? (if not, I don’t know if I’d trust it…)

7zip is the same as WinRAR or WinZip. All have been around for ages.