Problems with my Aegis Legend


#21

I suggest firmware update as generally it reset every setting to default. It does sound like there is something very wrong here tho.


#22

could well be a tiny slice of threading stuck in your 510, thus can be a right PITA sometimes to get out but it will do what you are describing, a toothpick can be good, I’ve also used compressed air in the past but that runs the risk of making it worse (blows the bur further down)
hope you manage to sort it :+1:


#23

@steve did you ever manage to resolve the issue?
The reason I ask is that I now have exactly the same problem.
I have tried multiple attys, as well as cleaning, and bouncing the 510 pin up and down, which moves freely.
Micrometer measurement in the connector is 4mm to the top of the pin, and the attys measure about 4.6mm so it is not that.
Even squirted WD40 in and cleaned.


#24

I’ve read about similar problems on geekvape facebook group. A few people reported that firmware update fixes the problem. A few other people are pissed off at geekvape and want their money back.


#25

It does seem to be a common issue.
I have even tried to update the firmware and am unable to do that either.
I have opened a ticket at Geekvape, and will see whether they either have a solution, or alternatively will offer a replacement unit.
Maybe this will just become an expensive paperweight.


#26

I hope you get it sorted out. I’ve had luck so far with geekvape, but the only mod of theirs I have is the gbox, and it never gave me issues (except once but juice got into battery compartment and a cleanup fixed it)


#27

Thought this was the best place to post this.
I had a call this afternoon from a customer who needed me to drop a new mod off to him at work as his old legend had had a bit of a malfunction. I asked him what the malfunction was and it turns out he was the malfunction. He put his mod down on the tracks of a 20-ton excavator and forgot it was there as he trundled off. I am going to see if I can bring it back but right now the batteries won’t fit in as it is a little squashed.

But I was pretty surprised at the condition considering a 20-ton excavator with steel tracks ran over it (the ground was a little soft as we had a few ml of rain today but still surprising)


#28

Good luck with that one mate.


#29

I have managed to get my Aegis Legend issued sorted out, the vendor replaced it for me.
Geekvape did eventually respond asking for me to supply all sorts of information, and lots of hoops to jump through, and also said that if they did decide to replace it I would have to ship the old one back to them.

Now however, my interest is peaked, I want to have a look inside it to see what is going on, I am however reluctant to “break it apart”, considering all the sealant they used in manufacture. I watched a video from DJLSB where he “dismantled” one and to be fair that was the end of that MOD.

If anyone has a clever way of achieving the impossible, I would be love to hear your suggestions.


#30

The sealant is just silicone they are not terribly difficult to take apart. You will need a new protective screen & some sealant to put it back together.

https://www.3avape.com/geekvape-aegis-legend-screen-frame.html

Open the battery door and remove the two plastic tubes that the batteries sit in - they are glued in and can be quite difficult.

Pry the front protective screen off with something flat like a butter knife after that everything is pretty easy.

Undo the four screws you see and cut the sealant with a hobby knife or similar

Undo the screws on top of the mod

Undo the screws holding the board into the chassis (gold ones on the board)

Remove the wire that connects up with the little pin that gets depressed when the bat door is closed - you may need to desolder as I did.

Once you have all the done the board and the top of the mod will be able to be seperated from the chassis.


#31

That is brilliant @woftam thank you for taking the time to explain, and add photos.
Was that the Aegis that the digger rode over?


#32

Yes mate it was


#33

I suppose it was shot hey?


#34

The board looks ok but i haven’t been able to get it to turn on - i suspect there is something i am missing and i will get back to it at some stage just havent had the time of late.


#35

I just hooked my thumb nail under the screen protector and it just popped off, not much silicone in there :rofl:
I’ll get into the rest of the operation tomorrow, thanks again.


#36

Ya that one is just dbl sided tape


#37

So much for Geekvapes IP67 rating of the Aegis Legend.
I managed to open the unit without any damage to the bodywork, so that was a plus.
However when I looked inside the casing it had a bunch of gunk in there, both dust and liquid.


That is the end of that piece of kit.
Very disappointing that this could happen with a unit marketed as “The Indistructible Beast”


#38

Now that pic i would send to Geekvape and say I aint sending it back but you owe me a new one. A subtle reference to posting it on every single bit of social media and forum related to ecigs in the world - they may not respond to threats but hey it is worth a shot


#39

Yes, I have actually sent the pic to them with some rather snarky comments, and also made mention of forums where I am a member.
The unit has actually already been replaced by the supplier that I use, so I’m not out of pocket fortunately, but it doesn’t bode well for Geekvape that their IP67 rated product is not really liquid and dust proof.


#40

Don’t worry as with most vape companies they will find a way to say it is your fault - geekvape are usually better than most but they will still chalk it up to user error somehow. At least you are not out of pocket - i would send a copy to your supplier as well just for a heads up.