The SteamCrave Supreme v.1 SC202 lives to fight another day

FINALLY got a day off, wooo hooooo. BUT (and there’s ALWAYS a BUT), one of my daily drivers locked up, and was looking like it MIGHT need to go bye bye. I don’t know about you guys, but I rate tearing down tanks, repairing, replacing o-rings at about the TOP of my HATE list LOL.

Yes, I have almost (but not quite), every SteamCrave tank in existence. I kinda fell off once they started getting MEGA BIG, but still have loads and loads. For whatever reason, I seem to just keep loving on the SC202, Supreme v.1. 7 mls, airflow, juice flow, and it came WITH the Velocity deck which of course rocks with my vertical coils. I forget what year SteamCrave released the Supreme v.1 but let’s just say it’s been a WHILE. This particular tank has been absolutely abused, and worked to death since I got it. Hundreds and hundreds of tank fills under it’s belt, it never complained, never failed, just plain worked, and chucked the flavor clouds.

After a recent cleaning, the juice flow ring just locked up !!! WTF ?? !!! Tear tank down, juice flow ring starts working again. Everything looks like it should, lube up with a couple of drops of VG, re-assemble, locks up again. WTF. This IS a big deal as on these (and many other SC’s), you MUST shut off the juice flow before removing the top cap and fill, then re-cap, then open, otherwise you risk flood dumping it.

OK, so now, I’m getting all teary eye’d, as this particular tank has been my daily driver forever. Dropped countless times, glass shattered a few times, battle scars covering it, etc.

I have spares, but just couldn’t toss this one. Completely dis-assembled, found it’s original box (with diagram LOL), and all the replacement parts, and o-rings that I just never really look at, after I photograph them for reviews.

Replaced EVERY o-ring, and it took a while. Grub screws were fine, replaced the EVER important stop pins, re-assembled, prayed, and BAMM. All is well again.

Fear not people, as you NEVER know what MIGHT just fix your beloved, older tank, and sometimes, JUST sometimes, actually USING some (or all) of the parts in your spare parts bags, MIGHT just work.

Back in the rotation again…


Well played :clap:


Glad you rescued it mate! Did you manage to pin down what the culprit was?


I’m sure it was one of the o-rings, but none were split, flattened, or abraded. But, when all of them were replaced, the issue went away. Go figure.


Very strange indeed. Well, glad you sorted it. Gotta love a happy ending :stuck_out_tongue:


Needed a firmware upgrade or aliens it’s always aliens

1 Like